Ubuntu 10.04 và các lỗi đã được xác nhận (tiếp theo)

Known Ubuntu 10.04(Lucid Lynx) issues/bugs with workarounds

Ngoài lỗi bản thân tôi đã gặp nêu ở đây, còn một số vấn đề hoặc lỗi khác nêu trong bài này. Tôi dịch và sửa lại đôi chút cho dễ làm hơn.

1-Đổi kiểu thanh địa chỉ của Nautilus

Thanh địa chỉ của Nautilus có hai dạng như hình trên. Dạng trên là kiểu “mẩu bánh mỳ” – breadcrumbs, dạng dưới là text. Trong các bản Ubuntu trước, chuyển đổi hai dạng này đơn giản bằng một cú kích chuột. Đến Ubuntu 10.04 để mặc định là dạng breadcrumbs và không kích chuột chuyển đổi được.

Muốn đổi từ dạng breadcrumbs sang text, nhấn cặp phím Ctrl+L. Từ text chuyển về breadcrumbs nhấn phím Esc.

Để đổi hẳn sang dạng text, nhấn Alt +F2 rồi chạy lệnh gconf-editor. Trong màn hình xuất hiện, ở cột bên trái tìm đến apps>nautilus> preferences rồi đánh dấu chọn mục always_use_location_entry ở cột bên phải.

2-Chuyển các nút điều khiển cửa sổ từ trái sang phải

Trong Ubuntu 10.04, các theme Ambiance (mặc định), Radiance và Dust có ba nút điều khiển cửa sổ đặt ở bên trái (giống MacOS). Các theme cũ vẫn để ba nút đó ở bên phải. Người sáng lập ra Ubuntu, Mark Shuttleworth, nói là để dành chỗ bên phải để tương lai sẽ đặt một cái gì đó vào đấy.

Có hai cách đổi các nút đó về bên phải. Cách 1 dùng gconf-editor như đã nói ở đây. Cách 2 làm như sau (giả sử ta định dùng theme Radiance):

1. System > Preferences > Appearance

2. Trong tab Theme chọn “New Wave” hoặc một theme cũ nào đó.

3. Nhấn vào nút “Customize..”

4. Chọn tab “Controls” rồi chọn “Radiance”

5. Chọn tab “Window border” rồi chọn “Radiance”

6. Chọn tab “Icons” rồi cuốn xuống dưới chọn “Ubuntu-mono-dark” rồi nhấn Close.

7. Chọn “Save as” rồi đặt tên theme mới nếu muốn.

Cách 2 không ảnh hưởng đến các theme sau này.

3-Một số touchpad không cuốn được màn hình

Mở terminal , chạy lệnh sudo nano /etc/modprobe.d/options rồi thêm dòng sau vào file options:

options psmouse proto=imps

Reboot lại máy.

4-Logo Ubuntu bị xấu khi khởi động

Sau khi cài các driver nguồn đóng chính hãng của các card màn hình Nvidia hoặc ATI (System>Administration>Hardware Drivers), logo Ubuntu lúc khởi động máy vừa to vừa xấu. Có hai cách khắc phục: chỉnh lại logo cho đẹp hoặc bỏ hẳn nó đi. Dưới đây là cách chỉnh logo.

1- Mở terminal (Applications>Accessories>Terminal)

2- Chạy lệnh sudo apt-get install v86d để cài gói v86d

3- Chạy tiếp lệnh sudo nano /etc/default/grub. (nếu chưa có nano thì sudo apt-get install nano). Trong màn hình trình soạn thảo gedit, dùng chuột bôi đen dòng sau đây (dòng 9):

GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash”

Copy dòng dưới đây:

GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash nomodeset video=uvesafb:mode_option=1280×1024-24,mtrr=3,scroll=ywrap”

rồi quay lại màn hình nano, vào menu Edit>Paste dán dòng vừa copy đè lên dòng đã bôi đen.

4- Vẫn trong màn hình nano, tìm đến dòng thứ 18:

#GRUB_GFXMODE=640×480

Xóa dấu # ở đầu và sửa hai số sau thành như sau:

GRUB_GFXMODE=1280×1024

5- Nhấn nút Save của gedit để lưu các sửa đổi trên lại rồi đóng màn hình.

6- Trong màn hình terminal chạy lệnh sau:

sudo nano /etc/initramfs-tools/modules

Trong màn hình nano, thêm dòng sau vào cuối file modules đang mở:

uvesafb mode_option=1280×1024-24 mtrr=3 scroll=ywrap

rồi Save và đóng màn hình lại.

7- Quay lại màn hình terminal, copy lệnh dưới đây dán vào terminal rồi Enter:

echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash

8- Vẫn trong màn hình terminal, chạy lần lượt hai lệnh:

sudo update-grub2

sudo update-initramfs -u

9- Reboot máy tính. Logo bây giờ sẽ gọn và đẹp.

Chú ý: các lệnh trên chỉ đúng với bootloader của Ubuntu 10.04 là grub2. Nếu đã thay grub2 bằng một bootloader khác thì trước khi thực hiện các bước trên phải cài lại grub2 bằng các lệnh sau trong terminal:

sudo apt-get remove grub

sudo apt-get install grub-pc

sudo grub-install /dev/sda

sudo update-grub2

5-Một số lỗi về card màn hình đã nêu trong Release Note

Để biết card màn hình đang dùng là loại nào, mở terminal (Applications>Accessories>Terminal) rồi chạy lệnh:

$ lspci -nn | grep VGA

Ví dụ kết quả của lệnh là:

00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02)

như vậy card màn hình là Intel 82852/855GM

Ngoài lỗi màn hình đen đã nói ở đây, trong Release Note còn nêu một số lỗi khác và cách khắc phục như sau:

a- Các cửa sổ bị lỗi khi dùng card ATI cũ (dưới 32MB RAM).

1- Mở terminal (Applications>Accessories>Terminal)

2- Chạy lệnh sudo service gdm stop

3- Chạy tiếp lệnh sudo Xorg -configure để cấu hình lại card màn hình.

4- Chạy lệnh sudo nano /etc/X11/xorg.conf để mở file xorg.conf. Trong màn hình gedit, thêm dòng Option “RenderAccel” “off” vào như sau:

Section “Device”

Driver “radeon”

Option “RenderAccel” “off”

EndSection

Save file và đóng màn hình gedit.

5- Trong màn hình terminal chạy tiếp lệnh sudo service gdm start

6- Khởi động lại máy.

b- Lỗi với card NVIDIA khi dùng driver của hãng.

Các driver card NVIDIA tải về từ site của hãng không dùng được. Người dùng nên cài driver qua System>Administration>Hardware Drivers.

c- Lỗi màn hình đen với card Intel i8xx

Các card màn hình Intel i845, i855 và một số loại i8xx khác bị lỗi màn hình đen. Ngoài cách đã nói ở đây, còn một số cách khắc phục lỗi khác .

CHÚ Ý: vì chưa biết nguyên nhân chính xác, nên không có một cách duy nhất. Các cách dưới đây có thể đúng cho từng trường hợp cụ thể.

Cách A: Kích hoạt lại KMS

Trong Ubuntu 10.04, KMS (Kernel Mode Settings) được disable đối với các card màn hình i8xx. Nếu các phiên bản Ubuntu trước, bạn không gặp lỗi màn hình đen thì có thể việc disable đó là nguyên nhân.

Để kích hoạt (enable) KMS, chạy lần lượt hai lệnh sau rồi khởi động lại máy:

echo options i915 modeset=1 | sudo tee /etc/modprobe.d/i915-kms.conf

sudo update-initramfs -u

Cách B: Chuyển sang dùng driver vesa

1- Mở terminal rồi chạy lệnh sudo nano  /etc/X11/xorg.conf

2- Copy rồi paste đoạn dưới đây vào file đang mở:

Section “Device”

Identifier “Configured Video Device”

Driver “vesa”

EndSection

Section “Monitor”

Identifier “Configured Monitor”

EndSection

Section “Screen”

Identifier “Default Screen”

Monitor “Configured Monitor”

Device “Configured Video Device”

EndSection

Chuyển sang dùng vesa khắc phục được 100% lỗi treo màn hình nhưng làm mất các tính năng 3D accelerated, video accelerated, HD resolution, …

Cách C: hạ cấp xuống dùng driver 2.8.0 -intel DDX driver

Driver 2.8.0 có tại x-retro PPA:

https://edge.launchpad.net/~ubuntu-x-swat/+archive/x-retro

Một số người thấy driver này tốt hơn bản 2.9 nhưng cũng có một số ảnh hưởng. Xem thêm tại ubuntugeek

Cách D: dùng kernel đời cũ

Bản kernel hiện tại là 2.6.32.21. Dùng lùi xuống một vài bản cũ hơn (chọn trên menu khởi động) có thể khắc phục lỗi hoàn toàn.

Cách E: Disable DRI

1- Nhấn Alt+F2 rồi chạy lệnh sau gksu gedit /etc/X11/xorg.conf:

2- Copy rồi paste đoạn dưới đây vào file đang mở:

Section “Device”

Identifier “Configured Video Device”

Driver “intel”

Option “DRI” “off”

EndSection

Cách này tắt mất 3D acceleration và đồ họa chậm hơn.

Cách F: dùng UXA Rendering

Tôi kích hoạt KMS, theo Cách A ở trên rồi theo cách “The Solution” “Method 2” tại địa chỉ này:

http://www.ubuntugeek.com/intel-graphics-performance-guide-for-ubuntu-904-jaunty-users.html

có kết quả tốt.

Card intel VGA của tôi là:

$ lspci -nn | grep VGA

00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02)

18 thoughts on “Ubuntu 10.04 và các lỗi đã được xác nhận (tiếp theo)

  1. Mấy hôm nay tính vào phản hồi mà ADSL ạch đụi hoài, bữa nay mới hồi phản được cái này: HP dv5t cài Ubuntu-10.04 xong, nhấn shutdown nhưng nó ì ra, cứ phải xài terminal để sudo halt. Có cách nào trị không bà con?

  2. Phản hồi về cái hồi phản trên kia:
    Bây giờ thì Ubuntu lại trơn tru shutdown “complete” chứ không còn ì ra hay nửa vời (tắt GUI nhưng các đèn LED vẫn sáng) như lúc đầu nữa. Xin nhấn mạnh là tôi chưa hề chạy bất cứ cái Fixbug nào hết.
    Sao kỳ zậy?
    Phải mở máy trở lại để gừi ngay mấy dòng xác nhận này.

    • Tôi có gặp trường hợp này với cả Ubuntu 9.04. Có lẽ là do trong quá trình shutdown một cái gì đó không tắt được. Nếu chịu khó xem log hệ thống chắc sẽ biết.
      Lần sau nó lại tắt được nên shutdown sẽ bình thường.

  3. Tôi làm theo cách bạn chỉ để sửa logo thì càng tệ hơn nó phải to gấp rưỡi và còn xấu hơn nữa. Giờ làm thế nào để trở lại như cũ trước lúc sửa đây? Chắc chắn là tôi không làm sai bước nào vì dùng U gần ba năm rồi.

  4. Tôi xóa một partition khác, cài lại Ubuntu-10.04 release, sau đó chạy update manager và chọn “all”. Rồi cài mc, stardict, scim-unikey, vv. Reboot lần nữa thì thu được kết quả ngon lành: mọi cái trơn tru, shutdown (GUI) tốt chứ không ạch đụi như lần cài trước.
    Xem kỹ lại thì thấy phần driver vẫn là default, mấy cái NVIDIA 173 và Current version recommended vẫn CHƯA enable. Có lẽ chính vì vậy mà màn hình startup hiện với chữ Ubuntu nhỏ đẹp (bằng cỡ khi boot LiveCD).
    Nhưng nếu máy xài Nvidia mà lại không cho Ubuntu update driver thì e là không kích hoạt compiz được. Cũng may đối với tôi cái compiz này là không cần thiết, có cũng hay mà không có cũng chả sao.

  5. Tôi đã làm theo cách để màn hình boot đẹp hơn, nhưng khi làm tới bước update-grub2 thì terminal báo là splash: not found. Giò phải làm sao đây?

  6. @HoangHieu: tôi gúc “splash not found” và tìm được đến đây: https://help.ubuntu.com/community/Grub2
    Trong đó hướng dẫn nếu bị not found thì ở bước trước sửa lại lệnh này:
    GRUB_GFXMODE=1280×1024
    thành
    GRUB_GFXMODE=1280×1024, 1024×768
    và dòng uvesafb mode_option=1280×1024-24 mtrr=3 scroll=ywrap
    có thể giảm chiều sâu màu từ 24 xuống 16 chẳng hạn.
    Tóm lại là các thông số trong hai lệnh trên phải phù hợp với màn hình và ảnh splash.

    • Tôi đã thử mọi cách trong trang https://help.ubuntu.com/community/Grub2 nhưng terminal vẫn báo là 9: splash: not found. Tôi sử dụng màn hình có độ phân giải là 1280×1024, VGA 8500GT rời, tôi cũng đã thử đổi đường dẫn hình nên trong /etc/grub.d/05_debian_theme nhưng vẫn ko có kết quả.
      //Nói thêm là khi vào, grub của tôi không hiện bảng chọn kernel mà vào thẳng, điều đó có bình thường không>?

      • Vụ này xương nhỉ. Thôi đợi tôi lặp lại, cố tình gây lỗi để mò xem sao.
        Hoặc thử remove rồi cài lại grub theo mấy lệnh ở cuối mục 4 ?
        Tôi đã làm với hai máy khác nhau đều ngon.

  7. tớ cũng google đến trang này và cũng mắc lỗi trên,thực ra sửa rất đơn giản.
    GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash nomodeset video=uvesafb:mode_option=1280×1024-24,mtrr=3,scroll=ywrap”

    đoạn này bạn xóa 2 dấu “” đi và gõ lại,vì khi copy paste noo sẽ paste nguyên kiểu hiển thị trên web,cho nên grub ko nhận đó là câu lệnh.Xóa đii gõ lại là lại update bình thường
    Goodluck😀

    • Đúng rồi. Tôi cũng đã một lần bị như thế khi chép từ web vào một file config và cũng phải sửa như vậy, nhưng lâu ngày quên mất điều đó.
      Tốt nhất khi sửa các file config bằng cách copy&paste thì làm bằng các trình soạn thảo trong giao diện text như nano, vi, không dùng các trình có giao diện đồ họa như kwrite, gedit.
      Tôi đã sửa lại phần đó.
      Thanks.

  8. Mình vừa cài Ubuntu 10.04. Khi mới login vào thì vẫn bình thường, nhưng chỉ hơn chục giây sau là máy đơ luôn không thao tác gì được. Đọc tài liệu trên mạng thấy Hệ điều hành này cần tối thiểu 256M Ram. Máy mình hiện là pen IV, 512M Ram. Mới tìm hiểu về Ubuntu nên chưa biết nhiều. Giúp mình với!

    • Máy đơ cũng có thể do file cài đặt (iso) hoặc đĩa CD hoặc ổ cứng có lỗi hoặc driver card màn hình không chuẩn, … nói chung là nhiều nguyên nhân lắm, không phải do RAM thiếu.
      Bạn có thể kiểm tra file iso qua checksum (MD5) xem khi tải về có lỗi gì không.
      Đĩa CD thì khi boot có lệnh kiểm tra lỗi. Tôi còn bị trường hợp ổ ghi CD bị lỗi, ghi bao nhiêu đĩa cũng không cài được.
      Ổ cứng thì có nhiều cách kiểm tra bad sector khác nhau.
      Nếu RAM không đủ chỉ bị chậm thôi, không đơ.
      Boot thử lại ở chế độ LiveCD, chạy vài chương trình thẳng từ CD, nếu không bị đơ thì do ổ cứng. Cài lại, khi format ổ chọn chế độ Advanced để kiểm tra các bad sector.
      Nếu máy yếu thì nên cài Lubuntu cho nhẹ.

      • Mình đã thử chạy ở chế độ LiveCD, vẫn bị đơ như vậy. Cài đĩa đó ở máy khác thì vẫn ngon lành nên file ISO chắc không có vẫn đề gì. Chắc do nguyên nhân phần cứng khác. Cảm ơn bạn nhiều!

Gửi phản hồi

Mời bạn điền thông tin vào ô dưới đây hoặc kích vào một biểu tượng để đăng nhập:

WordPress.com Logo

Bạn đang bình luận bằng tài khoản WordPress.com Log Out / Thay đổi )

Twitter picture

Bạn đang bình luận bằng tài khoản Twitter Log Out / Thay đổi )

Facebook photo

Bạn đang bình luận bằng tài khoản Facebook Log Out / Thay đổi )

Google+ photo

Bạn đang bình luận bằng tài khoản Google+ Log Out / Thay đổi )

Connecting to %s